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This tutorial can be found at http://tqewitt.wikispaces.com/XXXXXXXX.
An example website can be viewed at: http://tqewitt.com/advanced

This tutorial will walk participants through the development of a website. Since a website
needs content, we will use the lessons of this workshop as the content of our website.
Participants will go home with a website that they can use in the classroom.

Follow the steps below. Within this packet are the corresponding tutorials.

STEPS
 1. Create folder on Desktop
 2. Download template.html from Wiki- XXXXX
 3. View Online: Anatomy of a Website
 4. Fireworks: Create Buttons
 5. Fireworks: Create 2nd Buttons for Rollover
 6. Fireworks: Create Title Banner Graphic
 7. Dreamweaver: Open template.html
 8. Dreamweaver: Change CSS Styles
 9. Dreamweaver: Change Page Properties
 10. Dreamweaver: Change Table & Cell Properties
 11. Dreamweaver: Insert Title Banner Graphic
 12. Dreamweaver: Insert Buttons
 13. Dreamweaver: Create Rollover Buttons
 14. Dreamweaver: Link Buttons
 15. Dreamweaver: Create Pages Using “Save As…”
 16. Dreamweaver: Add Content to Pages
 17. Download Image from Pics4Learning.com
 18. Fireworks: Edit Photo
 19. Fireworks: Add Photo to Title Banner Image
 20. Dreamweaver: Insert Photos to “Photo Editing” page
 21. Download Image from Pics4Learning.com
 22. Fireworks: Give Photos Fancy Edges
 23. Dreamweaver: Insert Images to “Photo Finishes” page
 24. Upload and share websites
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Anatomy of a Webpage

 1. Title Banner
An eye-popping graphic with the website’s title that appears on every page. Any
font can be used for text. Textures, colors and photos make each banner unique.

 2. Navigation
Clearly organized area on every page that allows user to click through website
content. Navigation is traditionally made up of “buttons”.

 3. Button
Graphic that allows user to click to specified area of the website. Buttons can have
a rollover effect, appear 3D, and use any font.

 4. Table
Tables organize web content into different cells. Tables can be inserted within
other tables for a ‘nesting’ effect. Table Properties (background color, padding,
spacing and alignment) can be changed.
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 5. Cell
Cells are defined areas within a Table where content is placed. Cell background
can be changed. Images placed within a cell must not be larger than cell size.

 6. Styles
Styles are predetermined RULES for the properties of assigned text. Rules can be
edited in the Properties windows by clicking the ‘CSS’ button on the left. The
following Rules have been defined in your template:

a. .PageTitle
b. .ParagraphText
c. .HightlightedText

 7. Page Properties
Page title, default font, background color and images are defined here.
The properties can be changed either in the Properties window
or in Modify > Page Properties…

 8. Text (aka “Copy”)
The paragraphs of content for website.
The copy should be typed and edited BEFORE being placed inside cells.
Use either blank Dreamweaver pages or Text Edit to create copy.
DO NOT format text until copied and pasted into template.
One carriage return will create a space between paragraphs.
Copy will be formatted in Dreamweaver using CSS Rules.
The website should have no more than three styles of text.

 9. Graphics
Images for your website can come from cameras, scanning hand-drawn
illustrations, creating digital graphics using Fireworks, Photoshop, or any other
image editing software.
Images should be edited and properly sized BEFORE inserting them into your web
page in Dreamweaver.
All images MUST live in your project folder.
Images may not be moved around after insertion.
Image formats can include .png, .jpg, or .gif

 10. Color Scheme
Websites have a coherent look by sticking to a color palette of no more than three
colors and their varying shades.
Colors should compliment each other.
Text color should be readable on background color.
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Fireworks Button Tutorial
Creating A Button for
your website

Fireworks, like
Photoshop, is a
powerful professional
tool used by designers
and programmers
alike. You can use this
software for creating
original graphics, to
resize images, and
even for making
animated GIFs!

Try this basic tutorial
and then explore on
your own!

Create a folder for your work

Start a New Document
File > New

Width: 200
Height: 50
Pixels/Inch: 72

Draw a Shape for Your Button
Click on Rectangle in the Tool Box

Select a color
Draw rectangle
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Perfect the Size and Position of rectangle in Properties Menu:

W: 200    H: 50
X: 0         Y:0
(X and Y refer to the coordinates for positioning)

Add Filters To Rectangle

Go to the Properties Window

Click on the “+” next to “Filters”

Scroll down to “Bevel and Emboss”

Choose “Inner Bevel”

Experiment with the settings

Your button should look
something like this.

*Tip: You can remove Filters that you do not like by selecting the name of the filter in the
Properties Menu and clicking the “-“ to subtract it from your shape.
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Add Text to Your Button

Select a color

Select the Text Tool in the Tool Box

Position cursor in your button and type

Change font style and size

Use the Pointer Tool to move text

Add Effects from the Properties Window

*Tip: Text remains ‘live’ which allows you to go back and change any of the properties at any time.

Your button should look
something like this.

SAVING
One of the great things about Fireworks is that you can save it as a .png and insert it into
Dreamweaver as is. Then, should you want to change the font or the background color
of the button, you can open the .png file in Fireworks and easily make those changes.
Take that JPEG!

File > Save
Name the button “clickme.png”
Save it into your project folder

CREATE MULTIPLE BUTTONS
WITH ‘SAVE AS…’
Select the text.

Type “About Me”

File > Save As…

Name the button “aboutme.png”

Repeat!
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CUSTOMIZING “template.html”
in DREAMWEAVER

STYLES

CSS (Cascading Style Sheets) allow you to define styles for your site. There are many
benefits of using style sheets- design consistency, efficiency, and flexibility. We will be
using Internal Style Sheets this year. (External Style Sheets will be introduced next
year!)

The Properties window now has HTML and CSS options. You will be toggling between
both- pay attention to which you need for each step.

As illustrated in “Anatomy of a Webpage”, Styles apply to text using Rules. Three Rules
have been defined for your site:

a. .PageTitle
b. .ParagraphText
c. .HightlightedText

Editing the Rule “.ParagraphText”
 1. Click CSS in Properties window
 2. Select “.ParagraphText” in drop-down
 3. Click “Edit Rule”
 4. Change Font Family, Size, Color
 5. Click “Apply” to preview change
 6. Click “OK” to keep changes

Repeat these steps with .PageTitle and .Highlighted Text



Created by EWITT & Mighty Productions 2010. Cannot be reproduced without permission by Title IID.
  9

PAGE PROPERTIES

Page Properties allow you to define how the page looks- background color, link colors,
and the title that appears in the top window of browser windows.

Click Page Properties

Select “Appearance (CSS)”
and change Page font (this
should be set to the same
parameters as
.ParagraphText), and change
the Background color. Click
“Apply” to preview. Click
“OK” to keep changes.

Select “Links (CSS)” and
change the color of the
different states of a hyperlink
as it would appear in your
text.

Select “Title/Encoding” and
type in the title that will
appear on the browser
window.
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FUN WITH FIREWORKS
Photo Editing for Use With Title Banners

This tutorial will demonstrate tricks and techniques for combining PHOTOS with
GRAPHIC ELEMENTS & TEXT to produce unique images for your website projects.

TIP #1: Play!! Through playful exploration with the many color combinations, textures,
filters and options, you will create your own style. Make multiple images for fun before
committing to a look for your site.

TIP #2: “Bad artists copy. Good artists steal.” A favorite quote from Pablo Picasso is
a good practice for budding designers. Take a look at websites, magazines, television
commercials, etc. for inspiration for your own look. A great lesson would be to find a
design to mimic. Through the process of dissecting the design, many lessons will be
learned. Then, use the techniques learned from that lesson to create your own look.

Working with Pixels, a.k.a. Bitmap images
Imagine the digital images that you are working with are pieces of paper- you can cut out
shapes and specific images, you can paste images from different photos, you can layer
images on top of each other, you can put those images on a colorful textured
background and you can write and scribble all over the entire thing. Fireworks can mimic
all of these steps with logical tools and commands.

Photos are made of pixels, which make them a Bitmap image- as opposed to Vector
images, which we use to create shapes and text. Fireworks has organized the Tools
window into logical sections- you’ll see the Bitmap section with the tools used specifically
for working with pixels. The tools are:

Marquee- selects an area of pixels in both rectangular and oval shapes
Lasso (also Polygon Lasso)- selects an area of pixels in irregular shapes drawn by the
user. The Polygon lasso draws only straight lines from specified points.
Magic Wand- selects a continuous area of one color. (Select > Select Similar will then
select every instance of that color in the image.
Pencil, Paintbrush & Eraser- tools that behave like their name and come with many
options available in the Preferences window.
Blur tool (also Sharpen, Dodge, Burn and Smudge)- all tools that manipulate the
appearance of the image.
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Resizing Images
Determine the desired dimensions of the image by sketching out your page design on
the Paper Template. Most often, only one dimension is the ‘important’ dimension to pay
attention to. For instance, if creating an image to fit on half of the content area of your
template, you would make sure that the image’s width is between 250-280 pixels. The
same principle would apply if prepping an image to use on a title banner image (as
demonstrated in this tutorial) with the exception that you would keep the image larger
than the banner to leave room to shrink and crop.

File > Open
Select the image you would like to work with.

In the Properties Menu, click “Image Size”
to open the window to make changes

Alternate Route: Modify > Canvas > Image Size…

ORIGINAL SIZE NEW SIZE

NOTE: Only the “280” for the width was entered.
Because “Constrain proportions” is checked, FW
automatically calculated the height.

A Note on Viewing Your Image
FW will shrink the appearance of your
image to fit on the monitor. You might
be viewing a very large image at only
25% of its actual size.

Command “+” or “-” will zoom in or out of the image.



Created by EWITT & Mighty Productions 2010. Cannot be reproduced without permission by Title IID.
  12

Cutting Images out of a Photo

Just like working with paper, there are many ways to cut images out of a photo. For this
example, we want to focus on just the instructor and students. We need to cut away
everything else. We’ll use the Lassos and the Eraser to accomplish this task.

ORIGINAL IMAGE Step 1: Select with Polygon Lasso

• Select the Polygon Lasso tool
• Click a point and draw a line. Continue until

completely around the focal image and the
end of the line meets up with the beginning.
It might take a few tries to get used to it! Hit
“Esc” if you get stuck.
Don’t worry if it’s not perfect- eraser will fix it up.

• Select > Select Inverse
• Hit “Delete” on your keyboard
• Select > Deselect to get rid of marquee

LASSOED IMAGE

The checkered background represents
 where the image is transparent.

Step 2: Clean up with Eraser & Lasso

• Use the Eraser and/or Lasso to remove
any additional unwanted pixels.

• Adjust the size of the eraser accordingly.
• Hit “Delete” after using Lasso to select pixels
• Select > Deselect to get rid of marquee

Notice that the image has much more impact. Now you have a focal image to play with.
In this state you may apply Filters as Glow, Bevel and Emboss, apply artistic filters,
adjust the color, etc.
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Color Photo to Grey Scale

Click to select image
Filters > Adjust Color > Hue/Saturation…

Bring the toggle for Saturation all the way to the left

Grey Scale to High Contrast Black & White

Filters > Adjust Color > Brightness/Contrast
Bring both toggles towards the right and adjust to get the right look


